ГДЗ до підручника «Інформатика» Й.Я. Ривкінда. 8 клас

7.2. Призначення й використання математичних, статистичних, логічних функцій табличного процесора

Стор. 236

1. СУММ, СРЕДЗНАЧ, МАКС, МІН. Коли в комірку ввести знак «=», то в області імені комірки з’являється список функцій. Зі списку функцій вибираємо потрібну.

2. Як аргументи можна використовувати числа, текст, логічні значення, масиви, значення помилок чи посилання. Аргументи можуть бути як константами, так і формулами. У свою чергу ці формули можуть містити інші функції. Функції, що є аргументом іншої функції, називаються вкладеними.

3. Команда повного розгалуження в мові програмування Object Pascal має такий загальний вигляд:

If <логічний вираз>

then begin

<послідовність команд 1>

end

Else begin

<послідовність команд 2>

end;

Команда неповного розгалуження в мові програмування Object Pascal має такий загальний вигляд:

If <логічний вираз>

then begin

<послідовність команд 1>

end;

Дайте відповіді на запитання

Стор. 240

1. АВS(число), ROUND(число; кількість розрядів), SQRT(число), POWER (число; степінь), РІ().

2. SQRT(число), SUM(посилання; посилання) або SUМ(посилання:посилання).

3. AVERAGE (посилання:посилання), МАХ(посилання:посилання), ΜΙΝ(ποсилання:посилання).

4. Логічні вирази — це ті вирази, які містять знаки порівняння: >(більше), <(менше), =(дорівнює), <>(не дорівнює), >=(більше або дорівнює), <=(менше або дорівнює).

5. Логічні вирази можуть приймати значення True(істина) або False(хиба).

6. Загальний вигляд логічної функції IF такий:

ІF(логічний_вираз; значення,_якщо_істина; значення,_якщо_хибність).

7. Значення цієї функції визначається так:

  • обчислюється значення логічного_виразу (True чи False);
  • якщо логічний_вираз має значення True, то значення функції дорівнює значенню виразу значення,_якщо_істина;
  • якщо ж логічний_вираз має значення False, то значення функції дорівнює значенню виразу значення,_якщо_хиба;

8.

Загальний вигляд

Кількість аргументів

Результат виконання

AND (логіч1; [логіч2]; ...)

Від 1 до 255, усі, крім першого, необов’язкові

- True, якщо хоча б один аргумент має значення True;

- False, якщо всі її аргументи мають значення False

OR (логіч1; [логіч2]; ...)

Від 1 до 255, усі, крім першого, необов’язкові

- True, якщо аргумент має значення False;

- False, якщо аргумент має значення True

NOT (логічне)

1

- True, якщо всі її аргументи мають значення True;

- False, якщо хоча б один аргумент має значення False

Виконайте завдання

Стор. 241

1. В комірку В2 ввести формулу = КОРЕНЬ(СТЕПЕНЬ(В2;2) + СТЕПЕНЬ(В3;2)) і протягнути маркер.

2. В комірку G2 ввести формулу=СУМM(B2:F2) і протягнути маркер.

В комірку Н2 ввести формулу =MAKC(B2:F2) і протягнути маркер.

В комірку 12 ввести формулу =СРЗНАЧ(B2:F2) і протягнути маркер.

3. а) істина;

б) істина;

в) істина;

г) хиба;

д) хиба;

е) хиба;

є) істина;

ж) хиба.

4. В комірку С2 ввести формулу =И(В2>=$А$1) і протягнути маркер.

5. В комірку С2 ввести формулу =ЕСЛИ(В2>=85%;» Диплом І ступеня»; ЕСЛИ(В2>=75%;» Диплом II ступеня»; ЕСЛИ(В2>=50%;» Диплом III ступеня»; ЕСЛИ(В2<50;» Диплом учасника»)))) і протягнути маркер.

6. В комірку С2 ввести формулу =ЕСЛИ(ИЛИ(А2<-2;А2>10);2*А2-5;ЕСЛИ(И(А2>=2;А2<=3);3*А2+1; А2^5-4*А2^3)) і протягнути маркер.

7. В комірку С2 ввести формулу =В1+(В1*24)/100. В комірку D2 ввести формулу =С2+(С2*24)/100 і протягнути маркер по стовпцях.

В комірку С3 ввести формулу =В1+(В1*26)/100. В комірку D3 ввести формулу =С3+(С3*26)/100. В комірку Е3 ввести формулу =C3+D3.